Unable to git clone

Unable to git clone

6 posts / 0 new
Last post
rcampbell's picture
rcampbell
Points: 5
Unable to git clone

Hello,

I'm unable to clone the repository on my local windows based laptop using GIT Bash.

rjjjohnston@RJJOHNSTON /c/xampp/htodcs
$ git clone rcampbell@svn-1604.devcloud.hosting.acquia.com:rcampbell.git
Cloning into 'rcampbell'...
Permission denied (publickey).
fatal: The remote end hung up unexpectedly

I can login to the server via ssh using putty. I've tried loading the publickey into pageant but still unable to clone.

Any thoughts?

Thanks

Status: 
Resolved
rcampbell's picture
rcampbell
Points: 5

Additional setup is required beyond what documentation provides, see below:

For Git Bash

If you are running msysgit (I am assuming you are) and are looking to run Git Bash (I recommend it over TortoiseGit, but I lean to the CLI more than GUI now), you need to figure out what your home directory is for Git Bash by starting it then type pwd (On Win7, it will be something like C:\Users\phsr I think). While you're in git bash, you should mkdir .ssh.

After you have the home directory, and a .ssh folder under that, you want to open PuTTYgen and open the key (.ppk file) you have previously created. Once your key is open, you want to select Conversions -> Export OpenSSH key and save it to HOME\.ssh\id_rsa. After you have the key at that location, Git bash will recognize the key and use it

For TortoiseGit

When using TortoiseGit, you need to set the SSH key via pacey's directions. You need to do that for every repository you are using TortoiseGit with

Source: http://serverfault.com/questions/194567/how-to-i-tell-git-for-windows-wh...

Status Change: 
Resolved
brent.thomas@idfg.idaho.gov's picture
brent.thomas
Points: 0

This step is absolutely essential to get git working on windows. Can we have this step added to the windows documentation on dev cloud at https://docs.acquia.com/cloud/ssh/enable?

albert.martin's picture
Albert Martin
Points: 32

Thanks for the feedback here! I will send this over to our Documentation team for evaluation.

planetney@hotmail.com's picture
planetney
Points: 0

Please please please add this to the documentation or the video. Took me hours to get it going on windows.

gaurav@technostica.com's picture
gaurav
Points: 0

I tried both private key with pass phrase and without, but both time cloning is not working. GIT CLI is asking for passphrase both times and then permission denied error. Pleas help!