Unable to download modules and themes

Unable to download modules and themes

10 posts / 0 new
Last post
webmaster@phsc.edu's picture
webmaster
Points: 5
Unable to download modules and themes

Acquia Dev Desktop
Version 2
Built Apr 3 2015
Control panel rev 58769
Stack rev: 58529

Windows 7 Enterprise

Installed Dev Desktop and tried to download my Acquia Cloud site. Didn't work.

Created a new Drupal 8 site in Dev Desktop. Tried downloading D8 modules and themes via Drush and the update panel. Didn't work.

Getting the following errors on the Drush terminal window:
simplexml_loadfile(): I/O warning : failed to load external entity
"" Project.php:72
Failed to get available update data from https://updates.drupal.org/release-history/business/8.x
Could not download requested project(s)

Oh, I see you are having mollom problems too. Welcome to my world with Acquia!

Status: 
Resolved
bryn@wearereckless.com's picture
bryn
Points: 0

I had the same issue after upgrading to a newer Dev Desktop 2 release. I think one of the newer releases changed the default php version to 5.6 - try selecting 5.3, as for me this caused the problem to go away.

Cheers,

Bryn

webmaster@phsc.edu's picture
webmaster
Points: 5

That did it, almost. PHP 5.3 caused an error saying only 5.4 and above are supported. Switched to 5.4 and it was all good.

Thanks!

Status Change: 
Resolved
armstrong.664@osu.edu's picture
armstrong.664
Points: 0

This also worked for me with the added note that changing the default version of PHP did not take effect until Dev Desktop was completely shut down and then restarted.

chris.brookins@acquia.com's picture
chris.brookins
Points: 116

Sorry for the inconvenience - the default should have been PHP 5.5

emmons@email.arizona.edu's picture
emmons
Points: 0

5.5.23 didn't work for me but 5.4.39 did.

Any ETA on getting 5.5 to work? Our Acquia environments only allow me to set PHP to 5.5 or 5.6 but both of these in Acquia Dev Desktop 2 produce the error above and I can't use drush so I'm forced to run PHP 5.4 locally and I'm worried about environment mismatch (i.e. developer writes 5.4 code locally but it fails when pushed to Acquia Cloud).

andrezstar@gmail.com's picture
andrezstar
Points: 0

using php 5.6 and not working. Any solution?
It just suddenly happened. Yesterday it all properly worked.
Cheers

tony.zahler@century.edu's picture
tony.zahler
Points: 0

Try enabling your php openssl extension.

So goto php.ini search for "extension=php_openssl.dll" and enable it. It is disabled by default in 5.5 and 5.6, the future DevDesktop versions will enable it for all versions.

emmons@email.arizona.edu's picture
emmons
Points: 0

Woot! That worked -- thanks @tony.zahler !!

1. Switch PHP version for the desired site in the Acquia Dev Desktop 2 tool to 5.5.x or 5.6.x
2. Click the command-prompt icon in Acquia Dev Desktop 2 tool (to the right of "Local code")
3. Type the following to determine the loaded configuration file: php -i | findstr "php.ini"
4. Browse to where the indicated php.ini file exists and right click php.ini and select "Properties"
5. Click on the "Security" tab
6. Click "Edit..."
7. In the "Group or user names" list, click on "Users (..."
8. Click the "Allow" checkbox for "Modify"
9. Click "OK"
10. Click "OK" again
11. Open the "php.ini" file
12. Search for ";extension=php_openssl.dll"
13. Remove the leading ";" to enable the line (i.e. the line should just say "extension=php_openssl.dll" now)
14. Save and close the file
15. In the Acquia Dev Desktop 2 tool, click "Stop" in the bottom-right corner
16. After it stops, click "Start"
17. After it starts, in the command-prompt window try running the desired drush command

giforigin@gmail.com's picture
giforigin
Points: 0

Yes you should try enabling your php openssl extension.

TweakBox APK

AppValley APK