New Install Error

New Install Error

5 posts / 0 new
Last post
savinosolutions's picture
tsavino
Points: 0
New Install Error

I am trying to set this up behind our firewall at verizon I do have D5(we are using this in production)and D6 on a test server I put in the db info and then get this error:

Fatal error: Call to undefined function user_access() in /opt/hpws/apache/htdocs/drupala/includes/theme.inc on line 1687

Line 1687:
    if (user_access('access administration pages')) {
      $variables['is_admin'] = TRUE;

D5 seems to work fine on these hp 11.11 through 11.32 servers but I keep running into problems with D6
----------------------------------------------------------------------------------
My server config:
Drupal 6.6
Access to update.php Protected
Configuration file Protected
Cron maintenance tasks Last run 1 sec ago
Database updates Up to date
File system Writable (public download method)
GD library bundled (2.0.34 compatible)
MySQL database 5.0.27
PHP 5.2.6
PHP memory limit 500M
PHP register globals Disabled
Unicode library Standard PHP
Operations on Unicode strings are emulated on a best-effort basis. Install the PHP mbstring extension for improved Unicode support.
Update notifications Not enabled
Update notifications are not enabled. It is highly recommended that you enable the update status module from the module administration page in order to stay up-to-date on new releases. For more information please read the Update status handbook page.
Web server Apache/2.0.59 HP-UX_Apache-based_Web_Server (Unix) mod_perl/1.99_16 Perl/v5.8.8 DAV/2 mod_auth_kerb/5.0-rc6 PHP/5.2.6
----------------------------------------------------------------------------------
Status: 
Resolved
Joshua Brauer's picture
joshua
Points: 0

Hi Tom,

A couple of questions/ideas on this. Have you tried using an earlier version of Drupal 6.x? Using the AD ISR 1.0.2 for example would give an earlier version. I ask because it seems some folks are running 6.5 fine but seeing this when they try to move to 6.6. At a glance I don't see a change in the installer that would cause this but if it's the case it gives us a place to dig deeper.

Also you're installing in English using the latest Acquia Drupal tarball?

Have you tried re-downloading and unpacking the tarball on the server?

Thanks,
Josh
Acquia Technical Assistance Center

Thanks,
Josh
Acquia Client Advisory Team

savinosolutions's picture
tsavino
Points: 0

Did what you told be to do new tar ball gunzip on the server now I get the white screen of death no error's apache log said:
[Wed Dec 10 11:50:09 2008] [notice] child pid 14878 exit signal Illegal instruction (4).
I have D6.6 running on the same server working fine with no extra modules running but on that install I been working with panels people because I get the same white screen when I try to enable that module http://drupal.org/node/315869.

So I am at a impasse with D6 on the hp servers. Any help would be great.

Thanks Tom

Joshua Brauer's picture
joshua
Points: 0

Hi Tom,

Could you confirm this is the Acquia Drupal 1.0.3-ISR package (to be sure we're testing on the same version)?

I'm not clear on which version is running and where the errors are. It wounds like this server has some version of Drupal 6.6 running? And this is a new install on the same server? Is it a multi-site install or an install in a new directory?

When you're doing the installation are there any modules other than Acquia Drupal in the folders? Or is this dependent on the panels alpha being in place (but not installed).

Thanks,
Josh
Acquia Technical Assistance Center

Thanks,
Josh
Acquia Client Advisory Team

savinosolutions's picture
tsavino
Points: 0

Same server 2 different directorys 2 different installs and yes Acquia Drupal 1.0.3-ISR package no other modules is what I am trying to install.