installation failure

installation failure

31 posts / 0 new
Last post
pdeclarens@gmail.com's picture
pdeclarens
Points: 0
installation failure

this is the error message I get while instaling the 8.0 version
install_verify_datab in /Users/pascaldeclarens/Sites/devdesktop/drupal-8.0.0-rc3/vendor/symfony/dependency-injection/ContainerBuilder.php on line 868

I am running the latest Dev Desktop version on a Mac Mini; 16Go Ram; OS X El Capitan

thanks for your help

Status: 
Resolved (feature request)
ewbc1953's picture
Kipp.Watson
Points: 0

I tried installing the Acquia Dev Desktop 2 on a fresh Vista Home 64-bit virtual machine. The installation failed with a request that I post the installer.log and piscript.log on this forum. Added here is the installer.log which has been saved as installer.txt to fit into this upload module, but there does not appear to be any piscript.log in the DevDesktop folders.

Can anyone tell me what went wrong? is this a 32-bit 64-bit incompatibility matter?

Attachments: 
ahmedsiddiqone@gmail.com's picture
ahmedsiddiqone
Points: 3

I am using window xp, professional, service pack 2, version 2002, ERROR IS "problem running post install set up", only installer file is found no piscript is found..pls assist

Attachments: 
Status Change: 
Unresolved
svencooremans@hotmail.com's picture
svencooremans
Points: 0

Here the same problem. Skip the steps 'Choose profile' and 'Verify requirements' with the installations. This message shows up ' install_verify_database_settings('sites/drupal-8-...') #5 C:\Users\Wina\Desktop\ in C:\Users\Wina\Desktop\Sven Drupal\drupal-8.0.0\vendor\symfony\dependency-injection\ContainerBuilder.php on line 796' after set up database, using php 7.0.0.
How get started?

devonm1987@hotmail.com's picture
devonm1987
Points: 2

I'm also having a similar problem, trying to install Drupal 8. After the installation process creates a new site with Acquia Dev Desktop 2, I click on the local site link which prompts the install.php. I complete 'Choose Language', it skips 'Choose profile' and 'Verify requirements', I complete 'Set up database' and click [Save and continue], after loading for 3 seconds I get this Fatal error:

Fatal error: Uncaught exception 'Symfony\Component\DependencyInjection\Exception\InvalidArgumentException' with message 'The service definition "renderer" does not exist.'... ...\vendor\symfony\dependency-injection\ContainerBuilder.php on line 796

I saw a user question the error in the Drupal.org forum, they replied that the issue was with Dev Desktop and closed the ticket. Has a solution been found? Maybe a workaround??

Status Change: 
Unresolved
devonm1987@hotmail.com's picture
devonm1987
Points: 2

Also, after reloading the page, the display changes to:

The website encountered an unexpected error. Please try again later.

The local database link only opens after opening an already working drupal 7 local database link. Upon opening, the Drupal 8 database shows 23 tables. For reference, the drupal 7 install has 74 tables in the database.

Status Change: 
Unresolved
baroo's picture
bruceclark
Points: 8

I think it was me that was passed over to "file an issue in the dev desktop queue for this trough Report an issue from the help menu" but could not find support ticket availability. My problem is similar on installing database I get this:
++++++++++++++++++++++++
Fatal error: Uncaught exception 'Symfony\Component\DependencyInjection\Exception\InvalidArgumentException' with message 'The service definition "renderer" does not exist.' in C:\Users\Bruce\Sites\devdesktop\fiss2\vendor\symfony\dependency-injection\ContainerBuilder.php:796 Stack trace: #0 C:\Users\Bruce\Sites\devdesktop\fiss2\vendor\symfony\dependency-injection\ContainerBuilder.php(440): Symfony\Component\DependencyInjection\ContainerBuilder->getDefinition('renderer') #1 C:\Users\Bruce\Sites\devdesktop\fiss2\core\lib\Drupal.php(158): Symfony\Component\DependencyInjection\ContainerBuilder->get('renderer') #2 C:\Users\Bruce\Sites\devdesktop\fiss2\core\includes\install.core.inc(1151): Drupal::service('renderer') #3 C:\Users\Bruce\Sites\devdesktop\fiss2\core\includes\install.core.inc(1089): install_database_errors(Array, './sites/fiss2.d...') #4 C:\Users\Bruce\Sites\devdesktop\fiss2\core\includes\install.core.inc(366): install_verify_database_settings('sites/fiss2.dd') #5 C:\Users\Bruce\Sites\devdesktop\fiss2\core\includes\in in C:\Users\Bruce\Sites\devdesktop\fiss2\vendor\symfony\dependency-injection\ContainerBuilder.php on line 796
++++++++++++++++

Anyone out there? Not sure what to do :/

Status Change: 
Unresolved
dorene.a.thornley@co.ramsey.mn.us's picture
dorene.a.thornley
Points: 0

I was also getting the missing renderer error, trying to install on a Windows 7 machine, and now have a working site after following this tap dance -- I just had my success this morning, and have not determined which step(s) is the critical one; perhaps someone can refine them and report back; right now, it's chant the spell and the magic happens...
1) Grab a new, clean download from drupal.org; extract it into your dev desktop site folder.
2) Rename the folder to something without a hyphen (I used d8). Some reports I found on line claimed this error is caused by invalid characters in the site/database name. I tried creating a site w/o any odd characters and got the same error, but I left them out anyway. Make sure there is no database with your selected name.
3) Create the site using the "import local Drupal site" function on dev desktop. I had my site folder, database and site all have the same name. Do not click on the local site link when it's done. If you automatically clicked on it, start over.
4) Run command prompt as an admin. CD to the dev desktop folder where the new site is sitting. (I thought perhaps an admin user is necessary to create the renderer service, but did not see any such service listed.) User drush site-install to create the site.
5) Hopefully, you will now get a success message, and clicking on the local site link on dev desktop will open the site.
6) User 1 is named admin, use drush upwd admin --password="whatever" to change it.

I hope this works for you, and again, sorry I have not refined it to determine what the actual fix is. I believe it to be running drush as an admin.

dorene.a.thornley@co.ramsey.mn.us's picture
dorene.a.thornley
Points: 0

Sorry; missed a detail on step #3 -- I set php to 5.6.14 prior to importing the site.

svenivan@gmail.com's picture
svenivan
Points: 0

Thank you very much dorene.a.thornley!
I followed your instructions letter for letter and both surprised and very, very happy when it was working!

Great!

gsekmokas@hms.harvard.edu's picture
gsekmokas
Points: 0

Thank you dorene.a.thornley! Suggestion to use drush solved the problem, although I used default php version 5.5.30 and it worked fine. It is not necessary to use 5.6.14. Another detail - I don't get this error Mac OS 10.10.5 only on 10.11.1 El Capitan.
Also I used Acquia Desktop Dev 2 interface to download the Drupal 8 files and to create the database, then used drush as you suggested and everything worked fine, no more erors.

dorene.a.thornley@co.ramsey.mn.us's picture
dorene.a.thornley
Points: 0

The key is to merely to use drush first! It does not matter if you run it as an admin, and opening the site to use the GUI ruins it. So, here are the refined steps:

  1. Freshly extract the files to your dev desktop sites folder.
  2. Create the site using the "import local Drupal site" function on dev desktop. Set php to 5.5.30 o6 5.6.14.
  3. Do not click on the local site link when it's done. If you automatically clicked on it, start over.
  4. Run Drush from dev desktop, and type the command drush site-install.
  5. It will tell you the admin password, or reset it with the command drush upwd admin --password="whatever"

Done! This workaround is still necessary with 8.0.1; there will probably be a fix soon.

margaret.plett's picture
margaret.plett
Points: 0

Thanks @dorene.a.thornley!! I've been battling this off and on for a week. The key is not the dashes in the database name or an exact PHP version - it's really running drush site-install that saved the day.

info@mac-4-you.ch's picture
info
Points: 0

Hello,
Please excuse my very poor english (not exactly my mother tongue...)
I just wanted to thank you very much for your help! Your contribution helped me a lot to (finally...) install the 8.0.1 on my Mac (i7 Yosemite).
After days trying the installation, I only got the same "Fatal error: Uncaught exception...".
Now I can discover this new release!!!
Once again Thanks a lot!
Philippe

vq@dcar.us's picture
vq
Points: 5

I had the same problem - I uninstalled, removed all folders and reinstalled. This time I didnt change the default name of the site, the database AND i left the DB password blank. It still skipped the choose Profile and verify requirements but the install completed.

Status Change: 
Resolved
npcerobinson@gmail.com's picture
npcerobinson
Points: 0

I'm getting the same message. Created a clean install of Mac O/S 10.11 then DevDesktop-2-2015-07-27 and downloaded 8.0.1 from the Distribution list. DD created the new site, but then I received the Fatal Error message (attached).
I too searched the Drupal dot org website and found the same closed issue.
Does anyone have a suggestion of a workaround?

melanie_adcock@msn.com's picture
melanie_adcock
Points: 1

I have a 2010 Macbook Pro and I am having trouble downloading Acquia Dev Desktop 2. I attached a screenshot of the error message I was receiving. When I click okay and continue the install, it says that it program quit unexpectedly and if I hit reopen, the same message pops up! Please help me! I need to have this installed today.

Status Change: 
Unresolved
dan.stachlewski@gmail.com's picture
dan.stachlewski
Points: 1

I am running acquia dev desktop on Windows 10. Thanks to the Steps and Guidance suggested by dorene.a.thornley (5 comments up) I now have a copy of Drupal core 8.0.1 up and running.

Here is another possible way to successfully get Drupal working for you.

1. Download the distros from drupal
2. Create new DIR in sites/devdesktop | where your acquia dev desktop sites are located
3. Unzip the distros to the DIR
4. Click the + button and choose import local site from acquia dev desktop 2 (bottom left hand side)
5. Import the site
6. Click on the Open Drush Console on the right hand side of the Local Code: (newly imported site) in acquia dev desktop 2
This opens the console in the correct DIR
7. Type: drush site-install & press enter
It takes a little while and when finished the console will display:
a Username: admin
A generic Password="some random string"
**NOTE**. Take note of the username & password - you need them to change your profile
8. Click on the Local Site: URL in acquia dev desktop 2 and the installed distros will be displayed
9. Login with the generated Username & Password
10. Go to My Account or Profile and change the Username and Password to something more secure.

wrightrc@comcast.net's picture
wrightrc
Points: 0

Just like to say another "Thank You!" to *dorene.a.thornley* at post #12 that those simple steps worked perfectly to get things working in the Acquia Dev Desktop 2 (Version: 2, Built: Nov 22 2015 12:34:41, Control panel rev: 18a6124, Stack rev: db35aed) on OS X 10.9.5.

friedman_art@yahoo.com's picture
friedman_art
Points: 0

I'm unable to install Drupal 7.41 onto my imac OS X version 10.7.5.

Problem is similar to others reported here. See attached error banner. File piscript.log was not created. Acquia Dev Desktop crashed while starting up. The crash log follows the installer.log output listed below. None of the suggestions I found in the forum seem to help.

I can't imagine why running the following script should give a segmentation violation:

/Applications/DevDesktop/common/setup/postInstallPhp "/Applications/DevDesktop/common/setup/setup.php"

It seems that this script runs /Applications/Desktop/php5_4/bin/php, passing it the parameter /Applications/DevDesktop/common/setup/setup.php"

BTW, If I run /Applications/Desktop/php5_4/bin/php manually, without the parameter, ie,

I get an illegal instruction error. Seems like php itself is buggy? Compiled with bad options?

I don't see any way past this unless Acquia provides a correct php, install scripts, etc.

Any solutions? Response from Acquia?

Thanks.

Installer.log follows:

Log started 12/22/2015 at 16:51:08
Preferred installation mode : osx
Trying to init installer in mode osx
Mode osx successfully initialized
[16:51:12] OSX ver: 10.7.5
[16:51:12] Installer UI mode: gui
[16:51:12] Locations.ini found
[16:51:12] defInstDir:/Applications/DevDesktop defSitesDir:/Users/artfriedman/Sites/devdesktop
Preparing to Install
Preparing to Install
Creating directory /Applications/DevDesktop
.
.
.

Running post install script. This may take a couple of minutes.
Executing /Applications/DevDesktop/common/setup/postInstallPhp "/Applications/DevDesktop/common/setup/setup.php"
Script exit code: segmentation violation

Script output:

Script stderr:
child killed: segmentation violation

Error running /Applications/DevDesktop/common/setup/postInstallPhp "/Applications/DevDesktop/common/setup/setup.php": child killed: segmentation violation
Problem running post-install step. Installation may not complete correctly. For assistance, please finish the installation and post a new forum message to bit.ly/dd-bugs with these files:
/Applications/DevDesktop/installer.log
/Applications/DevDesktop/piscript.log

==stdout==

Creating Uninstaller
Creating uninstaller 25%
Creating uninstaller 50%
Creating uninstaller 75%
Creating uninstaller 100%
Installation completed
Log finished 12/22/2015 at 16:52:20
Executing open "/Applications/DevDesktop/Acquia Dev Desktop.app"
Script exit code: 0

Script output:

Script stderr:

kelman@onetel.com's picture
kelman
Points: 0

Drush seems to work fine for single sites but what about multisite. I cannot repeat this for adding any multisites as Drush will only apply to the default. Entering drush site-install someothersitename just invokes the default install.

Any suggestions, Please?

aphickey@tiac.net's picture
aphickey
Points: 0

For multi-site: follow Dorene a Thornley's excellent instructions above for the first site. For the second site, choose New Drupal Multi-site under the "More" button in DevDesktop 2. As with the first site, DON'T CLICK ON THE LINK for the site. Instead, open up phpAdmin by using the Open database manager... link in the same 'more' menu in DDT 2. Export the database of the first site that you completed with drush into a sql file. Pay attention to where you saved it, because you'll need it for the next step.. Import that database into the db for the second site in your multi-site. GO back to Devdesktop. You should then be able to click on the link for the second site now.

manisha.patravali@gmail.com's picture
manisha.patravali
Points: 0

I am unable to resolve this issue as Drush fails for me ..Its says enable drush from more drupal environment .
Is there any other method or any help to get drush working...

manisha.patravali@gmail.com's picture
manisha.patravali
Points: 0

well I tried by starting using the start a fresh website and choose a distribution from the drupal list that pops...I choose drupal 8.0.1 and then did not click on the web link but first went to drush and did a site install and then contd...Thank you Dorene a Thornley's excellent instructions and dan as well...
Thanks a ton!!!

kelman@onetel.com's picture
kelman
Points: 0

Thank you for that step-by-step! That got rid of the error but now I'm looking at a multisite displayed as a directory list as though no theme is set as default (See image). Only the main page displays correctly with the Bartik theme but all others do not. The default site has no such issue. I didn’t change the db name when I imported it; could this be causing a conflict?

Attachments: 
aphickey@tiac.net's picture
aphickey
Points: 0

I had the same problem with the theme. I just went into the appearance section and chose the bartik theme again. That seemed to fix it locally.

kelman@onetel.com's picture
kelman
Points: 0

I tried that thinking the same thing but selecting any theme / saving had no effect. Seems to me the multisite is broken. Will have to start over again.

jpcp@optusnet.com.au's picture
jpcp
Points: 0

Just wanted to say a big thanks to dorene.a.thornley post 8 and dan.stachlewski post 18 for help in finally getting drupal 8 installed...I had errors I did not understand and came across this and install worked. On a side note the solutions offered works with drupal 8.0.2

Once again a big thanks :)

john@johnKirkley.com's picture
john
Points: 0

Lame. Can't you guys get this fixed?

eschrepel@nwcouncil.org's picture
eschrepel
Points: 0

Agreed, and granted I'm a newbie to Drupal (we currently develop in Umbraco, but exploring Drupal for an additional site), and are mostly a Windows-environment organization. But so far, these 3 different attempts to explore Drupal have failed:

  1. 1) Create site in Acquia Cloud (tried to add Google Visualization and other modules, got various errors in the process)
  2. 2) Install Drupal via Microsoft Web Platform Installer (countless errors and varying answers about how to set file permissions to install modules, etc.)
  3. 3) Run Acquia Dev Desktop, which resulted in the error message in this thread.

I imagine we'll next explore putting the WAMP stack on our dev server and seeing if we can get things working that way.

tim.whelan@ibb.gatech.edu's picture
tim.whelan
Points: 0

That worked perfectly. Thanks fro sharing!!!