incorrect local ssl cert

incorrect local ssl cert

6 posts / 0 new
Last post
larsomat@uwec.edu's picture
larsomat
Points: 0
incorrect local ssl cert

Hello!

I just downloaded acquia dev desktop and it works very easily, except for one thing: SSL.

First of all, when I visit https://test.dd:8443/ there is an ssl error where Chrome says the site is not secure. The second thing is when I try to run my migrations that use curl to access a secure endpoint, curl complains that it cannot open the cert file which is supposed to be located at "/Applications/DevDesktop/common/cert/cacert.pem" however, when I go to that directory, it's not called "cacert.pem", but there are 2 files in there, "devdesktop.crt" and "devdesktop.key"...

I cannot find information anywhere on how to get it to work, and I've tried searching for awhile now.

Thanks in advance for any ideas :)

~Matt

Status: 
Unresolved
chabotweb@gmail.com's picture
chabotweb
Points: 0

I am having the same problem. Any help would be greatly appreciated!

chabotweb@gmail.com's picture
chabotweb
Points: 0

Hey Matt,

I actually finally found a solution to the curl problem that worked for my configuration. Basically, I just downloaded the cacert.pem file and saved it in the /Applications/DevDesktop/common/cert/ directory (or for me, because I'm on Windows: \Program Files (x86)\DevDesktop\common\cert).

I got the cacert.pem file from: https://curl.haxx.se/ca/cacert.pem

And I got the solution from StackOverflow: http://stackoverflow.com/questions/24611640/curl-60-ssl-certificate-unable-to-get-local-issuer-certificate

After restarting dev desktop, it worked like a charm.

hth!

Michelle

shakti1418@gmail.com's picture
shakti1418
Points: 0
onlineapplicationform1@gmail.com's picture
onlineapplicationform1
Points: 0
milanjoy1990@gmail.com's picture
milanjoy1990
Points: 0

I have gone through this article and read about the problem you have discussed here about SSL. I didn’t have much idea about this issue, but after reading other commentators review, I think it will help you to solve your issue. Complete Care Health Center South Gate