error:14077419:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert access denied

error:14077419:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert access denied

3 posts / 0 new
Last post's picture
Points: 0
error:14077419:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert access denied

Greetings all,

My team has installed Acquia Dev Desktop and we have imported an existing Drupal 7 site. The site works mostly OK but a lot of site functions aren't working. Specifically areas of the site that make HTTP requests to remote services is broken. We also get similar errors during Drupal login. The error recorded in the Drupal DB log is consistent:

"error:14077419:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert access denied"

We don't know what could be causing this. The live site does not have this issue (not hosted on Acquia Cloud). When I installed Dev Desktop I selected PHP version 5.6.29 which is the closest to our live site (running 5.6.31). My colleague selected 5.6.19. I am on Mac OS X and my colleague is on Windows 7, and we both get the same error SSL error as above. We are behind a corporate firewall.

I tried modifying /Applications/DevDesktop/tools/vendor/drush/drush/includes/ as this post recommends:

But this did not help. I also see that some people have recommended that the version of OpenSSL needs to be updated, but I don't know what version I should use with Acquia Dev Desktop, or how I might upgrade OpenSSL within Dev Desktop. If it turns out that this error results from being behind a corporate firewall, how might we resolve this issue?

Can someone please help?

Pending Bug Fix's picture
Points: 0

United Parcel Service (UPS) is the largest parcel/package delivery company. UPS is one of the leading global providers of supply chain management solutions and logistics services.'s picture
Points: 0