Can't install Drupal Commons Maximum Execution Time

Can't install Drupal Commons Maximum Execution Time

24 posts / 0 new
Last post
SangriiaAdmin's picture
espencer2
Points: 0
Can't install Drupal Commons Maximum Execution Time

Hi. I am trying to install Drupal Commons but am receiving this error message:

Fatal error: Maximum execution time of 300 seconds exceeded in C:\wamp\www\drupal_commons\includes\file.inc on line 934

I have updated the PHP.ini and .htaccess files.

I'm trying to evaluate Acquia for a project but I can't even load it.

Status: 
Unresolved
ken0's picture
ken
Points: 0

I am getting the same error when trying to install Drupal Commons. Have you by chance found a solution?

ken0's picture
ken
Points: 0

This is what I'm getting in my PHP error log.

[14-Sep-2010 16:27:10] PHP Warning: Table 'db_dc_test.access' doesn't exist
query: SELECT 1 FROM access WHERE type = 'host' AND LOWER('127.0.0.1') LIKE LOWER(mask) AND status = 0 LIMIT 0, 1 in V:\test-sites\dc\includes\database.mysqli.inc on line 128

[14-Sep-2010 16:27:10] PHP Warning: Table 'db_dc_test.users' doesn't exist
query: SELECT u.*, s.* FROM users u INNER JOIN sessions s ON u.uid = s.uid WHERE s.sid = 'fqpcktkp78gdb5vsr2daougja4' in V:\test-sites\dc\includes\database.mysqli.inc on line 128

[14-Sep-2010 16:27:10] PHP Warning: Table 'db_dc_test.cache' doesn't exist
query: SELECT data, created, headers, expire, serialized FROM cache WHERE cid = 'variables' in V:\test-sites\dc\includes\database.mysqli.inc on line 128

[14-Sep-2010 16:27:10] PHP Warning: Table 'db_dc_test.variable' doesn't exist
query: SELECT * FROM variable in V:\test-sites\dc\includes\database.mysqli.inc on line 128

[14-Sep-2010 16:27:10] PHP Warning: Table 'db_dc_test.cache' doesn't exist
query: UPDATE cache SET data = '', created = 1284496030, expire = 0, headers = '', serialized = 0 WHERE cid = 'variables' in V:\test-sites\dc\includes\database.mysqli.inc on line 128

[14-Sep-2010 16:27:10] PHP Warning: Table 'db_dc_test.system' doesn't exist
query: SELECT name, filename, throttle FROM system WHERE type = 'module' AND status = 1 AND bootstrap = 1 ORDER BY weight ASC, filename ASC in V:\test-sites\dc\includes\database.mysqli.inc on line 128

[14-Sep-2010 16:27:10] PHP Warning: Table 'db_dc_test.url_alias' doesn't exist
query: SELECT COUNT(pid) FROM url_alias in V:\test-sites\dc\includes\database.mysqli.inc on line 128

[14-Sep-2010 16:28:05] PHP Fatal error: Maximum execution time of 30 seconds exceeded in V:\test-sites\dc\includes\file.inc on line 934

[14-Sep-2010 16:31:36] PHP Fatal error: Maximum execution time of 30 seconds exceeded in V:\test-sites\dc\includes\file.inc on line 934

EDDYL's picture
e.loiseau
Points: 0

Hi,
I have downloaded acquia package today and wanted to try it, but I am experiencing the same 'max execution time' error, at the same line.

I am running it on localhost. Have you manage to fix it ?

Does anyone around have an idea on how to fix it ?

Regards,
Edouard

Chris Rutter's picture
chris.rutter
Points: 0

Can you try adding the following line to your /sites/default/settings.php file:

ini_set('max_execution_time', 0);

Please let me know if that helps clear up this issue?

Thank You,
Chris Rutter
Acquia Client Advisory Team

Thank You,
Chris Rutter
Acquia Client Advisory Team

alexi721's picture
alexi721
Points: 0

This didn't fix the problem. I am on a PC using WindowsXP.

Thank you,
Alex

Chris Rutter's picture
chris.rutter
Points: 0

I have escalated this issue to engineering. I hope to have an update for you on this shortly.

Internal Tracking: SP-629

Thank You,
Chris Rutter
Acquia Client Advisory Team

Thank You,
Chris Rutter
Acquia Client Advisory Team

ltantot's picture
ltantot
Points: 0

We still did not receive a response from Chris Rutter's ticket. Chris could you please give us an update on the ticket.

Thanks to John Doyle I finally finished the installation of Commons. It is SLOW as SLOW is possible. It's really far from what i see in the demo. Is it me or you guys face the same problem. As such it is UNUSABLE from my point of view.

Thanks you four your feedback

Chris Rutter's picture
chris.rutter
Points: 0

Can you please try adjusting your php.ini's max_execution_time, then restart apache and try the installation again.

Thank You,
Chris Rutter
Acquia Client Advisory Team

Thank You,
Chris Rutter
Acquia Client Advisory Team

alexi721's picture
alexi721
Points: 0

I searched the web without success for a solution, but discovered that this installation issue happens to many others as well under Windows.

Is there nobody at Acquia who has a Windows machine?
It would be great if Acquia could at least acknowledge there is a problem and that somebody is working on a fix.

Thank you,
Alex

TedMurphy's picture
ted
Points: 0

Same problem, blank screen when I try to install the Acquia Drupal Commons. As an aside, I am able to install the default Drupal off of the same screen. I am also able to install acquia-drupal-1.2.30.

I select the Drupal Commons installation profile, hit Save and Continue, and after about 40 secs I get:

FastCGI Error
The FastCGI Handler was unable to process the request.

Error Details:

* The FastCGI process exceeded configured activity timeout
* Error Number: 258 (0x80070102).
* Error Description: The wait operation timed out.

HTTP Error 500 - Server Error.
Internet Information Services (IIS)

I am running on an Windows box using an IIS server. My PHP is Version 5.3.3 and MySQL is 5.1.51-community.

alexi721's picture
alexi721
Points: 0

After hours searching the web and debugging the issue I figured out the problem.

I installed 'Drupal Commons' via the Acquia Control Panel, which creates its own directory with a 'settings.php' file.

After adding

ini_set('max_execution_time', 0);

the installation was successful.

At all my other Drupal sites the settings file is at '/sites/default/settings.php.' Naturally this doesn't work for sites using the Acquia CP.

PS:
I also increased the times from 60 to 300 for the following two variables in the php.ini file:
max_execution_time = 300
max_input_time = 300

ken0's picture
ken
Points: 0

After two months of hoping for a fix it's finally here. Thanks Alex for finding that. It took a long time for the install to complete but at least it made it through.

kaicyee's picture
kaicyee
Points: 6

Thanks a lot for the tip, Alex for doing all that research but it's still not working for me. Did you have to reload Drupal Commons into DAMP again from scratch. Thanks again

subodh10's picture
kumarsubodh.vicky
Points: 0

I have got the same error but by setting max_execution_time=300 in php.ini file, I have resolved the issue.

samadams83's picture
adams.sam
Points: 0

I had to change core files.
I ended up making two temporary core changed to get it to install:
1. replaced line 687 of the install.inc file from:
"$installs = drupal_get_install_files($module_list);"
to:
"$installs = array();"
It's hacky, but it GREATLY speeds up the process, and since we know that the distro fresh-out-of-the-box has all it's requirements, there is no need to check them.

2. In case it helps anyone else, i was also getting an error like this:
"You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') ORDER BY fit DESC LIMIT 0, 1' at line 1 query: SELECT * FROM drupal_menu_router WHERE path IN () ORDER BY fit DESC LIMIT 0, 1 in ...includes/menu.inc on line 315"

Which is solved by modifying line 315 in menu.inc from:
"if ($router_item = db_fetch_array(db_query_range('SELECT * FROM {menu_router} WHERE path IN ('. implode (',', $placeholders) .') ORDER BY fit DESC', $ancestors, 0, 1))) {"
to:
"if ($placeholders && count($placeholders) > 0 && $router_item = db_fetch_array(db_query_range('SELECT * FROM {menu_router} WHERE path IN ('. implode (',', $placeholders) .') ORDER BY fit DESC', $ancestors, 0, 1))) {"

hope that helps

frost's picture
mike2357
Points: 0

trying to install latest full release. FTP'd to my VPS, created database & db user, set rights to settings file, etc. Same server that has lots of running Drupal installations.

First I was getting a simple timeout message, so udpated htaccess and settings.php
then got as far as database step and get lots of MySQL server has gone away errors

The server is a 'nix box, and as mentioned it runs a lot of other Drupal sites with no issues, so spec isn't an issue

TRAN AN's picture
stylisq
Points: 0

Chris !
Thank YOU !
It's working for me.

JDoyle's picture
jdoyle
Points: 0

I was having this problem and seem to have solved it. I have successfully installed commons on Windows Server 2008 with IIS7 using PHP 5.3.3 and MySQL 5.2.5. I was going back and forth between the timeout and an error about missing the GD library.

I noticed that no matter what I did to my php.ini file, my call to PHPInfo() never changed. It turned out that the PHP file had an error in it so it was loading the default values.(To check this, I went to the PHP folder C:\PHP in my case and typed in php -v and I received a popup message saying that there was an error on line xxxx.)

Once this issue was fixed and I made the necessary changes to the config file and I added this line:

ini_set('max_execution_time', 0);

to my settings.php file and I was able to make it through the verify requirements section.

I also noticed that after I put in my database information and hit save and continue, I got a blank white screen. After checking the log files, it turns out that the timeout problem was back. The line that I added to the settings.php file was removed between requirements checking and the database part. After adding this line back into the file, I was able to successfully install Drupal Commons.

Once the install was complete, I had no formatting on the website. It was saying it could not load a file because it did not exist. This was a temp folder issue. After going to Site Configuration -> File system -> Settings and changing the temp folder path from 'C:\windows\temp' to 'sites/default/files/temp' the formatting was fixed and I have a clean Drupal Commons Install working.

Hope this helps.

ltantot's picture
ltantot
Points: 0

max_execution_time updated->still slow

It was set to 60 in my php.ini. I set it to 10 but the result is still SLOW.
I wonder if somebody, out of you guys at Acquia, successfully install and run Commons.

Brenda Boggs's picture
brenda.boggs
Points: 0

Hi Lionel,

I'm not sure which ticket you are referring to, but I'm curious where are you running Commons? Because Commons includes several contributed Drupal modules, it will require more than a vanilla Drupal install from your system. We run Commons internally and I've done quite a bit on a local copy and have not run into the slowness issues you are describing. Could you provide more detail on your system/server specs and what you are doing on the site that is slow?

Thanks,

Brenda Boggs

Brenda Boggs
Acquia Client Advisory Team

Brenda Boggs's picture
brenda.boggs
Points: 0

Hi Ted,

Did you up your max_execution_time?

If that doesn't resolve it, try upping your RequestTimeout and ActivityTimeout in your fcgiext.ini file and restart IIS.

Brenda Boggs
Acquia Client Advisory Team

Brenda Boggs
Acquia Client Advisory Team

Brenda Boggs's picture
brenda.boggs
Points: 0

Thanks for reporting back on your findings, Alex. Glad to hear this resolved this issue for you.

Brenda Boggs
Acquia Client Advisory Team

Brenda Boggs
Acquia Client Advisory Team

asad10987t@gmail.com's picture
asad10987t
Points: 0

a debt of gratitude is in order for this usefull article, sitting tight for this article like this once more. Brian Holm Attorney San Diego