Can't get composer to work

Can't get composer to work

7 posts / 0 new
Last post
2440media's picture
contact
Points: 0
Can't get composer to work

I'm using the latest Dev Desktop on Windows. When I try to run a composer command, it errors out with:

php.exe composer.phar
Could not open input file: composer.phar

Any idea why it doesn't work or how I can fix it?

thanks

Status: 
Unresolved
anand.shankar1711@gmail.com's picture
anand.shankar1711
Points: 0

I am also facing the same issue. I am not able to composer commands.
Also, if someone could guide on how to install (or if already pre-installed) the PHPCS library so that it can be configured with the Netbeans IDE for run time inspection of coding standards.
Also, how can we configure Drupal Console if we are using Acquia Dev Desktop (ADD) V2.
Prior to this I was using Ubuntu and everything was so easy to configure but now I am restricted to use Windows and ADD.

Any help would be highly appreciated.

corkerton's picture
corkerton
Points: 2

I am using Drupal 8 and I am trying to install the address module using the Acquia Dev Desktop. This also needs composer in order to install. I am getting the same error Could not open input file: composer.phar

Is there a workaround? This is a real show stopper.

Status Change: 
Unresolved
aondo@sjc.org's picture
aondo
Points: 1

Has anyone solved this? I'm experiencing the same problem.

Status Change: 
Unresolved
nicholas.alipaz@heremedia.com's picture
nicholas.alipaz
Points: 0

A coworker was having this issue and we traced it down to the path set in the DevDesktop\tools\composer.bat file. We added quotes around the php path, and made it absolute. Doing so allowed it to execute. We also changed the composer.phar path to be absolute with double-quotes since we wanted to be able to run composer from anywhere. After doing so she could run:

@SET PATH=%PATH%;"C:\Program Files (x86)\DevDesktop\php5_6"
php.exe "C:\Program Files (x86)\DevDesktop\tools\composer.phar" %*

to run composer in a directory
nianaronaz@gmail.com's picture
nianaronaz
Points: 0

I cherish these suggestions and I believe a regularly expanding number of educators begin to treat summer thusly. do my assignment uk

barbarae's picture
barbara.errickson
Points: 0

WOW - thank you !! That worked for me ;-)

barbarae