Error opening socket ssl://search.acquia.com:443 -- SOLVED!

Error opening socket ssl://search.acquia.com:443 -- SOLVED!

3 posts / 0 new
Last post
nickgajewski's picture
nickgajewski
Points: 0
Error opening socket ssl://search.acquia.com:443 -- SOLVED!

Hey everyone,

I've been fighting this bug for a while so I thought I'd post here:

Recently something got borked with Acquia Solr Search. It worked fine locally for weeks then last week I started getting two errors: the standard "cannot connect to Acquia..." on search pages and this one popped up on the Apache Solr Config page:

Error opening socket ssl://search.acquia.com:443

After hours (days?) of backing-up and wiping DBs, playing with D7/Acquia configurations, messing with Firewalls, etc, I found this post (https://network.acquia.com/node/387025) which pointed to a similar error and it's solution was to remove the rpc.acquia.com.pem file. While going to that file I noticed that there was a similarly named search.acquia.com.pem file. I renamed it (search.acquia.co1m.pem) and voila (!) search works locally again!!

High fives were had.

Long story short: deleted the search.acquia.com.pem file if you're having this problem!

Acquia people:
- care to tell me what the problem is?
- why can I post in this forum but not in the Solr forum?

Status: 
Unresolved
thowell's picture
Thomas Howell
Points: 30

Hello Nick,

I've moved this ticket into the appropriate forum area. Thank you very much for the details of your troubleshooting. When there is a mismatch issue regarding the key removing the file should allow it to rebuild with a correct one. Can you confirm if the file updated itself after deletion?

Sincerely;
Thomas Howell, Client Advisor

johne's picture
johne
Points: 12

I am having this issue, can someone describe where to find either rpc.acquia.com.pem or search.acquia.com.pem?